Your Freedom account's Mail Blocking feature allows you to set access restrictions based on individual email addresses, hostnames, or even top level domains such as .cc or .my.
Your /etc/mail/access file contains a list of email addresses and/or domain names from which you wish to restrict access to your mail server. You can edit this file to maintain your own email blacklist.
To restrict access to your mail server, Telnet or SSH to your Freedom account and follow the steps below:
Go to your /etc/mail/ directory and pico the access file:
> cd /etc/mail
> pico access
Enter all the addresses or domains, one per line, for which you wish to restrict access, according to the following format:
sender restriction
Note: You must use a TAB to separate the values for sender and restriction.
The sender can be an email address (user@domain.tld), full domain (domain.tld) or top-level domain (.tld). The restriction can be any of the following:
REJECT – Returns an "accessed denied" code to the sender.
DISCARD – Deletes the message with no further action. Does NOT return a message to the sender.
RELAY – Allows a sender to relay through your Freedom account.
As in the above example, place each entry on a separate line, and separate each restriction with a tab.
Close the file and run the following command to update the access database:
> mailctl restart
This command updates (or creates) your /etc/mail/access.db database file using the entries contained in the /etc/mail/access file.
Example: Suppose you wish to reject all mail from the individual address 'spammer@aol.com' and to discard any mail received from 'cyberspammers.com.'
To do so, you would need to add the following to your /etc/mail/access file:
spammer@aol.com REJECT
cyberspammers.com DISCARD
As in the above example, be sure to type only one address or domain per line, and to separate the sender and the restriction with a TAB.