In the vhosts.conf file, all lines starting with a pound sign (#) are comments, and are ignored by your virtual server.
Configuration settings contained in a Virtual Host entry apply only when a request is received for the specified domain. These configuration settings override the defaults defined in /www/conf/defaults.conf where conflicts occur. A typical Virtual Host entry contains the following commands, or directives:
<VirtualHost></VirtualHost> - Contains all configuration directives for a virtual host
DocumentRoot - The location from which Web pages are served for the virtual host
ServerName - The name your Freedom account should take when requests come addressed to the virtual host
ServerAlias - Any additional domain or canonical that points to the main domain (ServerName) of the virtual host
ServerAdmin - The email address of the virtual host's administrator, which appears on error pages generated at the virtual host's Web site
LogFormat - The format of the virtual host's log files
ErrorLog - The location of the virtual host's error_log file
TransferLog - The location of the virtual host's access_log file
HostNameLookups - Enables DNS lookups so that host names can be logged. Because it is network-intensive, it is recommended that you keep HostNameLookups turned off unless you need this information.
<Directory></Directory> - Contains the location and configuration directives for directories associated with the virtual host, including the virtual host's Document Root and cgi-bin directory (if enabled)
There are many additional configuration options that you can use with virtual hosting. Many of the configuration directives listed at the Apache Web site can be included in a Virtual Host entry: